re = /(?<!\S)@\.?[\w.-]{2,}/m
str = 'george want@to play @.hdgska football @dddada'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end