$re = '/\/?([^\/]+?\/[^\/]+)\/?$/m';
$str = '/Users/foo/a/b/c
/Users/foo/a/b/c/
/Another/example/
/Another/example
short/url
short/url/
/something/that/is/super/long/with/lots/of/slashes
/something/that/is/super/long/with/lots/of/slashes/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);