$re = '/([\d.]+)\s*MiB/';
$str = 'Uploaded Today 13:11, Size 117.09 MiB, ULed by demonoidt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);