package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Size\s*([\d.]+)`)
var str = `Uploaded Today 13:11, Size 117.09 MiB, ULed by demonoidt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}