$re = '/(\w+)(?:#(\d+))?/m';
$str = 'ABC#99999
9ABC#8
9ABC
9ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);