$re = '/^\d{8,9}$/m';
$str = '12345678
123456789
123
1234567890
1234567*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);