const regex = /(\d)\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)\\1', 'gm')
const str = `sda123123de3443k55ffhh6788`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);