$re = '/(Error validating properties for broker :)[a-zA-Z0-9 \'\']*$.^((?!Exception).)*Exception:[:;,\.\'\'\-\_àèìòùÀÈÌÒÙáéíóúýÁÉÍÓÚÝâêîôûÂÊÎÔÛãñõÃÑÕäëïöüÿÄËÏÖÜŸçÇߨøÅ寿œ\w\d \t]*/ms';
$str = '2/11/2021 17:14:20;=======================================================================
2/11/2021 17:14:20;stg
2/11/2021 17:14:20;stg else
02/11/2021 17:14:20;=======================================================================
02/11/2021 17:14:20;Starting test for : OUTBOUND RabbitMQ
02/11/2021 17:14:51;Error validating properties for broker : OUTBOUND RabbitMQ
java.lang.Exception: ERREUR::Exception lors de l\'ouverture du channel[Connection timed out: connect]
at com.mom.utils.ClientUtils.openChannel(ClientUtils.java:80) ~[classes/:na]
at com.mom.properties.RabbitMqOutboundProperties.testConfig(RabbitMqOutboundProperties.java:61) ~[classes/:na]
at com.mom.BrokerConfigurationTester.main(BrokerConfigurationTester.java:73) ~[classes/:na]
02/11/2021 17:14:51;=======================================================================
02/11/2021 17:14:51;Starting test for : INBOUND MqSeries
02/11/2021 17:14:53;Error validating properties for broker : INBOUND MqSeries
com.ibm.msg.client.jms.DetailedIllegalStateException: JMSWMQ0018: Echec de la connexion au gestionnaire de files d\'attente \'QMFINOUT\' à l\'aide du mode de connexion \'Client\' et du nom d\'hôte \'Client\'.
at com.ibm.msg.client.wmq.common.internal.Reason.reasonToException(Reason.java:489) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.msg.client.wmq.common.internal.Reason.createException(Reason.java:215) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.msg.client.wmq.internal.WMQConnection.<init>(WMQConnection.java:456) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.msg.client.wmq.factories.WMQConnectionFactory.createV7ProviderConnection(WMQConnectionFactory.java:8683) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.msg.client.wmq.factories.WMQConnectionFactory.createProviderConnection(WMQConnectionFactory.java:8023) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.msg.client.jms.admin.JmsConnectionFactoryImpl._createConnection(JmsConnectionFactoryImpl.java:322) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.msg.client.jms.admin.JmsConnectionFactoryImpl.createConnection(JmsConnectionFactoryImpl.java:242) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jms.MQConnectionFactory.createCommonConnection(MQConnectionFactory.java:6026) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jms.MQQueueConnectionFactory.createQueueConnection(MQQueueConnectionFactory.java:142) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.mom.utils.ClientUtils.openAndTestJmsConnection(ClientUtils.java:130) ~[classes/:na]
at com.mom.properties.MqSeriesProperties.testConfig(MqSeriesProperties.java:57) ~[classes/:na]
at com.mom.BrokerConfigurationTester.main(BrokerConfigurationTester.java:73) ~[classes/:na]
Caused by: com.ibm.mq.MQException: JMSCMQ0001: L\'appel IBM MQ a échoué avec le code achèvement \'2\' (\'MQCC_FAILED\') ; motif \'2538\' (\'MQRC_HOST_NOT_AVAILABLE\').
at com.ibm.msg.client.wmq.common.internal.Reason.createException(Reason.java:203) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
... 10 common frames omitted
Caused by: com.ibm.mq.jmqi.JmqiException: CC=2;RC=2538;AMQ9204: Connexion à l\'hôte \'inmifbatqpm1.rouen.francetelecom.fr(1415)\' rejetée. [1=com.ibm.mq.jmqi.JmqiException[CC=2;RC=2538;AMQ9205: Le nom d\'hôte fourni n\'est pas valide. [3=inmifbatqpm1.rouen.francetelecom.fr,4=TCP]],3=inmifbatqpm1.rouen.francetelecom.fr(1415),4=,5=RemoteTCPConnection.resolveHostname]
at com.ibm.mq.jmqi.remote.api.RemoteFAP$Connector.jmqiConnect(RemoteFAP.java:13605) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.api.RemoteFAP$Connector.access$100(RemoteFAP.java:13143) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.api.RemoteFAP.jmqiConnect(RemoteFAP.java:1448) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.api.RemoteFAP.jmqiConnect(RemoteFAP.java:1389) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.ese.jmqi.InterceptedJmqiImpl.jmqiConnect(InterceptedJmqiImpl.java:377) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.ese.jmqi.ESEJMQI.jmqiConnect(ESEJMQI.java:562) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.msg.client.wmq.internal.WMQConnection.<init>(WMQConnection.java:389) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
... 9 common frames omitted
Caused by: com.ibm.mq.jmqi.JmqiException: CC=2;RC=2538;AMQ9205: Le nom d\'hôte fourni n\'est pas valide. [3=inmifbatqpm1.rouen.francetelecom.fr,4=TCP]
at com.ibm.mq.jmqi.remote.impl.RemoteTCPConnection.resolveHostname(RemoteTCPConnection.java:651) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.impl.RemoteTCPConnection.parseConnectionName(RemoteTCPConnection.java:480) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.impl.RemoteTCPConnection.protocolConnect(RemoteTCPConnection.java:1341) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.impl.RemoteConnection.connect(RemoteConnection.java:995) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.impl.RemoteConnectionSpecification.getNewConnection(RemoteConnectionSpecification.java:572) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.impl.RemoteConnectionSpecification.getSessionFromNewConnection(RemoteConnectionSpecification.java:246) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.impl.RemoteConnectionSpecification.getSession(RemoteConnectionSpecification.java:154) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.impl.RemoteConnectionPool.getSession(RemoteConnectionPool.java:127) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
at com.ibm.mq.jmqi.remote.api.RemoteFAP$Connector.jmqiConnect(RemoteFAP.java:13345) ~[com.ibm.mq.allclient-9.2.3.0.jar:9.2.3.0 - p923-L210708]
... 15 common frames omitted
02/11/2021 17:14:53;=======================================================================
02/11/2021 17:14:53;stg
02/11/2021 17:14:53;stg else
02/11/2021 17:14:53;=======================================================================';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);