package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z_-]+(?:\h[a-zA-Z_-]+)*$`)
var str = `abd d
a bdc
abd de
ab cde`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}