$re = '/^(?:([A-Za-z`0-9@#$%^&*\-_=+\'/.,])(?!.*\1))*$/';
$str = 'asdf6@';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);