package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z][a-zäöü'-](?:[\w'-]+)?)`)
var str = `Smith
Müller
McDonald
O'Riley
Lee
Li
Manco-Johnson
MIsspelled`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}