re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[_\-!#*@&])[A-Za-z\d_\-!#*@&]{8,30}$/m
str = 'HelloWorld123!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end