$re = '/v?(\d+)\.(\d+).*/m';
$str = 'v1.41
1.53.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);