$re = '/(?|(1a)|(2a)|(1b))\1/m';
$str = '1a1a 2a2a 1b1b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);