re = /[\p{L}-—]+(?:\h[\p{L}-—]+)*(?=,)?/m
str = ' втор-ой шанс, в эт—от же мир, перерождение, хитрость и обман'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end