const regex = /^(?=.*[\d])(?=.*[a-z])(?=.*[A-Z])(?=.*([^\w\s]|[_]))(\S+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[\\d])(?=.*[a-z])(?=.*[A-Z])(?=.*([^\\w\\s]|[_]))(\\S+)$', 'gm')
const str = `123456789
123ABCDEF
123ABDdef
123ABCdeF\$
123ABCdeF_
123ABCdeF\$ 1234
123ABCdeF\$ 1ABC
123ABCdeF\$ 1Abc
123ABCdeF\$ 1Ab\$
123acC&
123acC &
test@123
test_@123A
test_@123A sdf
_123456789
_123ABCDEF
_123ABDdef
_123ABD def
1Ab2
1Ab!
!123
!ABC
!1Ab
123_
1AB_
1Ab_
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}