#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^}\R(?=[A-Z])"
Local $sString = "I(0,123...789){" & @CRLF & _
"A(0,567...999){.......n=Marc.....}" & @CRLF & _
"B(2,655...265){..................}" & @CRLF & _
"C(3,993...333){..................}" & @CRLF & _
"M(8,635...254){.................;}" & @CRLF & _
"}" & @CRLF & _
"O(0,345...789){" & @CRLF & _
"A(0,567...999){.......n=Marc.....}" & @CRLF & _
"B(2,876...775){..................}" & @CRLF & _
"C(3,993...549){..................}" & @CRLF & _
"M(8,354...987){.................;}" & @CRLF & _
"}" & @CRLF & _
"I(0,987...764){" & @CRLF & _
"A(0,567...999){.......n=Marc.....}" & @CRLF & _
"B(2,543...265){..................}" & @CRLF & _
"C(7,998...933){..................}" & @CRLF & _
"M(8,645...284){.................;}" & @CRLF & _
"}" & @CRLF & _
"B(0,123...789){" & @CRLF & _
"......." & @CRLF & _
"}" & @CRLF & _
"I(0,987...764){" & @CRLF & _
"A(0,567...999){.......n=John.....}" & @CRLF & _
"B(2,543...265){..................}" & @CRLF & _
"C(7,998...933){..................}" & @CRLF & _
"M(8,645...284){.................;}" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")