# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<posting_date>\d{2}/\d{2}/\d{4})\s+(?P<transaction_date>\d{2}/\d{2}/\d{4})\s+(?P<description>[\w\s(),:]+?)\s+(?P<Amount>-?\d{1,3}(?:\s\d{3})*\.\d{2})\s+(?P<Balance>-?\d{1,3}(?:\s\d{3})*\.\d{2})$"
test_str = ("26/01/2023 26/01/2023 Payment Received Z Kona 8 000.00 8 085.87\n"
"26/01/2023 26/01/2023 Banking App Payment: Sihle -2 000.00 6 085.87\n"
"26/01/2023 26/01/2023 Payment Fee -1.50 6 084.37\n"
"26/01/2023 26/01/2023 SMS Payment Notification Fee -0.25 6 084.12\n"
"26/01/2023 26/01/2023 Payment Received Z Kona 15 000.00 21 084.12\n"
"26/01/2023 26/01/2023 Payment Received Z Kona 1 500.00 22 584.12\n"
"26/01/2023 26/01/2023 Payment Received Z Kona 2 000.00 24 584.12\n"
"26/01/2023 26/01/2023 Banking App Transfer to Ms K Savings (1816578655) -18 500.00 6 084.12\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.