using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""asento\"": ((?:(?!(\""vasen\""|\""oikea\"")).)*),\s*$";
string input = @"""asento"": ""vasen"",
""asento"": ""oikea"",
""asento"": 42,
""asento"": false,
""asento"": null,
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}