package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(aa|bb)`)
var str = `hahahahahabbjajajajaaabababababbkakoaoakoakoa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}