import re
regex = re.compile(r"^[a-z0-9.!#$%&'*+\/=?^_`{|}~-]+@[a-z0-9](?:[a-z0-9-]{0,64}[a-z0-9])?(?:\.[a-z0-9](?:[a-z0-9-]{0,64}[a-z])?){1,2}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("bhagat.ali@gmail.com\n"
"bhagat.ali@gmail\n"
"abhagat@capitalone.com\n"
"bhagat.ali@gmail.co.in\n"
"bhagat.ali@gmail.co-in\n"
"bhagat.ali@gmail.co.\n"
"bhagat.ali@gmail.co.in.ca\n"
"bhagat.ali@gmail.co.in.ca.\n"
"bhagat.ali@gmail...com\n"
"ali!b@gmail.com\n"
"ali#b@gmail.com\n"
"ali$b@gmail.com\n"
"ali%b@gmail.com\n"
"ali&b@gmail.com\n"
"ali'b@gmail.com\n"
"ali***$$$b@gmail.com\n"
"ali+++b@gmail.com\n"
"ali////b@gmail.com\n"
"ali===Tets@gmail.com\n"
"ali????b@gmail.com\n"
"ali^^^^^^b@gmail.com\n"
"ali____b@gmail.com\n"
"ali````b@gmail.com\n"
"ali{{{{}}}}b@gmail.com\n"
"ali|||||b@gmail.com\n"
"ali~~~~b@gmail.com\n"
"ali------b@gmail.com\n"
"bhagat.ali@12345678901234567890123456789012345678901234567890123456789012345678.com\n"
"bhagat.ali@12345678901234567890123456789012345678901234567890123456789012345.com\n"
"bhagat@c.99a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")