re = /map-class frame-relay TempMap_1.*(?:\R\h+.*)*/
str = '!
map-class frame-relay TempMap_1
frame-relay cir 1536000
frame-relay bc 15360
frame-relay mincir 281000
frame-relay adaptive-shaping becn
service-policy output AB_TEMP_F1536K_0-256K-384K-128K_18
logging trap debugging
logging source-interface Loopback1
logging 136.91.111.21'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end