re = /(?:http[s]*\:\/\/)*(.*?)\.(?=[^\/]*\..{2,5})/i
str = 'http://livephish.nugs.net'
# Print the match result
str.match(re) do |match|
puts match.to_s
end