using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(__Internal64\.PlotHistogram(?:2D)?(?:_\d+)?\(.*)(__arg(?:5|6))(.*)";
string substitution = @"$1new IntPtr(&$2)$3";
string input = @"__Internal64.PlotHistogram(label_id, values, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_1(label_id, values, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_2(label_id, __arg1, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_3(label_id, __arg1, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_4(label_id, __arg1, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_5(label_id, __arg1, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_6(label_id, __arg1, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_7(label_id, __arg1, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_8(label_id, __arg1, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram_9(label_id, __arg1, count, bins, bar_scale, __arg5, flags)
__Internal64.PlotHistogram2D(label_id, xs, ys, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_1(label_id, xs, ys, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_2(label_id, __arg1, __arg2, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_3(label_id, __arg1, __arg2, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_4(label_id, __arg1, __arg2, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_5(label_id, __arg1, __arg2, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_6(label_id, __arg1, __arg2, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_7(label_id, __arg1, __arg2, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_8(label_id, __arg1, __arg2, count, x_bins, y_bins, __arg6, flags)
__Internal64.PlotHistogram2D_9(label_id, __arg1, __arg2, count, x_bins, y_bins, __arg6, flags)
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}