$re = '`([^/?]+)/?(?:$|\?)`';
$str = 'https://www.example.com/post/abc-def/?p=294';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);