package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^[:digit:]]`)
var str = `c("district1", "district1", "district1", "district1", "district2", "district2", "district3")
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}