$re = '/^-(?!0*\.?0+$)\d*\.?\d+$/m';
$str = '-.000
-0
-0.0
-0.00
-12
-244
0
1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);