re = /\w+(?:[.-]\w+)*@\w+(?:[.-]\w+)*(?:\.\w{2,3})+/m
str = 'https://www.test.com/?token=_JxY5kgHdKMkO8uSYf77sEl9mJhD7NHwAlrsMfJ-1zg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end