re = /(?>\p{L}\p{M}*+)+/m
str = 'Андре́й Серге́евич Арша́вин (род. 29 мая 1981[4], Ленинград) — российский футболист, бывший капитан сборной России, заслуженный мастер спорта России (2008).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end