import re
regex = re.compile(r"^\/([a-zA-Z\-]+\/)?(admin((\/[a-zA-Z0-9\-_&=?]*)*|$)|(user\/(login|password)(\/?\?[a-zA-Z0-9\-_&=]*|$)))$", flags=re.MULTILINE)
test_str = ("/admin/valadas/gyfhsdfgsdjf/DHGSDJHFSF/sdjsdh?a=23&b=13\n\n"
"/user/password/?teste=1212&teste=1234\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")