import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[A-Z-][ ]){9,}[A-Z])\\s+([A-Z \\n',.-]+)\\b(?![A-Z]+(?=\\.))\\b(?![a-z']|[A-Z.])(.*?)(?=(?:[A-Z][ ]){9,}|This book \\n)";
final String string = "This is some introduction text.\n\n"
+ "Here's the table of contents:\n\n"
+ "ONE \n\n"
+ "The Boy Who Lived · 1 \n"
+ "TWO \n\n"
+ "The Vanishing Glass · 18 \n"
+ "THREE \n\n"
+ "The Letters from No One · 31 \n\n"
+ "FOUR \n\n"
+ "The Keeper of the Keys · 46 \n\n"
+ "C H A P T E R O N E \n\n\n\n\n"
+ "THE BOY WHO LIVED \n\n"
+ "Mr. and Mrs. Dursley, and their greatest fear was that somebody would discover it. \n"
+ "• 1 • \n\n"
+ "CHAPTER ONE He couldn’t know that at this very moment, people meeting in secret all over the country were holding up their glasses and saying in hushed voices: “To Harry Potter — the boy who lived!” \n"
+ "• 17 • \n\n\n\n"
+ "C H A P T E R E X A M P L E\n\n\n\n"
+ "IT'S A NEW CHAPTER\n\n"
+ "WITH. SEVERAL, EDGE-CASES\n\n"
+ "EDGECASE. The chapter continues...\n\n"
+ "C H A P T E R T W O \n\n\n\n\n"
+ "THE VANISHING GLASS \n\n"
+ "Nearly ten years had passed since the Dursleys Everybody knew that Dudley’s gang hated that odd Harry Potter in his baggy old clothes and broken glasses, and nobody liked to disagree with Dudley’s gang. \n"
+ "• 30 • \n\n"
+ "C H A P T E R T H R E E \n\n\n"
+ "THE LETTERS \n\n\n\n"
+ "FROM NO ONE \n\n"
+ "The escape of the Brazilian boa constrictor earned with Dudley this summer. . . .” \n"
+ "• 309 • \n\n"
+ "This book \n"
+ "was art directed by \n"
+ "David Saylor and designed by Becky \n"
+ "Terhune. The art for both the jacket and interior was \n"
+ "created using pastels on toned printmaking paper. The text was \n"
+ "set in 12-point Adobe Garamond, a typeface based on the sixteenth- \n"
+ "century type designs of Claude Garamond redrawn by Robert \n"
+ "Slimbach in 1989. The book was printed and bound \n"
+ "at RR Donnelley & Sons, Willard, Oh. \n"
+ "The production was supervised by \n"
+ "Angela Biola \n\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}