# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|\n)\s*Name\s*(?<name>[\w\W]+?)\s+Address\n(?<address>[\w\W]+?)\s+Date of Birth\s+(?<dob>[\w\W]+?)\s+Nationality\s*(?<nationality>[\w\W]+?)(?=\s)"
test_str = ("Name\n"
" Christopher Robert York\n"
" Address\n"
" Lyric House 6b St Andrew Street\n"
" Hertford\n"
" Hertfordshire\n"
" SG14 1JA\n"
" Date of Birth\n"
" 24/12/1961\n"
" Nationality\n"
" British\n\n"
" Directorships for Mr Christopher Robert York\n"
" Company Number Name Status Position Appointed Date Credit Limit Risk Score\n\n"
" 12432488 �� CASTLE LEGAL SERVICES LTD Non trading Director 29/01/2020 £0 0\n\n"
" 03075887 �� CREDITSERVE LTD. Company is dissolved Company Secretary 31/07/2006 £0 0\n\n"
" 03075887 �� CREDITSERVE LTD. Company is dissolved Director 04/07/1995 £0 0\n\n"
" 06534336 �� CREDITSERVE BUSINESS INFORMATION LIMITED Active - Accounts Filed Company Secretary 29/09/2008 £7,500 55\n\n"
" 06534336 �� CREDITSERVE BUSINESS INFORMATION LIMITED Active - Accounts Filed Director 13/03/2008 £7,500 55\n\n"
" Ms Laura York\n"
" Name\n"
" Laura York\n"
" Address\n"
" Lyric House 6b St Andrew Street\n"
" Hertford\n"
" Hertfordshire\n"
" SG14 1JA\n"
" Date of Birth\n"
" 01/06/1964\n"
" Nationality\n"
" British\n\n"
" Directorships for Ms Laura York\n"
" Company Number Name Status Position Appointed Date Credit Limit Risk Score\n\n"
" 06534336 �� CREDITSERVE BUSINESS INFORMATION LIMITED Active - Accounts Filed Director 01/04/2011 £7,500 55\n\n"
" Company Secretary")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.