$re = '/{{(.+?)\/(.+?)\|({.+?}\|)(}})/';
$str = '{{ First String/Second String|{Thing1}|{Thing2}|{Thing3}|{Thing4}|}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);