import re
regex = re.compile(r"^[M|m]etalocalypse\ [s|S](\d\d)[e|E](\d\d)", flags=re.MULTILINE)
test_str = ("Metalocalypse s03e01.avi\n"
"Metalocalypse s03e01.srt\n"
"Metalocalypse s03e02.avi\n"
"Metalocalypse s03e02.srt\n"
"Metalocalypse s03e03.avi\n"
"Metalocalypse s03e03.srt\n"
"Metalocalypse S03E04.avi\n"
"Metalocalypse s03e04.srt\n"
"Metalocalypse s03e05.avi\n"
"Metalocalypse s03e05.srt\n"
"Metalocalypse s03e06.avi\n"
"Metalocalypse s03e06.srt\n"
"Metalocalypse s03e07.avi\n"
"Metalocalypse s03e07.srt\n"
"Metalocalypse s03e08.avi\n"
"Metalocalypse s03e09.avi\n"
"Metalocalypse s03e09.srt\n"
"metalocalypse s03e10.avi\n"
"Metalocalypse s03e10.srt")
subst = "Metalocalypse.S\\1E\\2.XviD"
result = regex.sub(subst, test_str)
if result:
print(result)