re = /(?=.)(.*?)(?:\[([^\][]*)\]\(([^()]*)\)|$)/m
str = 'textA [aaa](bbb) textB [ccc](ddd) textC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end