package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([^)(]+|(?0))\)`)
var str = `((A^¬B)->C)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}