$re = '/(.)(?!\1)(.)\2\1/m';
$str = 'Any 4 char sequence which has a pair of two different characters followed by the reverse of that pair e.g xaax or raar. The string is not considered valid if the pattern above exist in square brackets.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);