$re = '/(?:\G(?!^);|Sections:)\s*\K[BCDE]\d+/i';
$str = 'Sections: B3; C2; D4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);