const regex = /(?!^)\b[A-Z]\w*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^)\\b[A-Z]\\w*', 'gm')
const str = `I went to to go see my friend John yestWerday.
John and I are good friends.
-I like John, she said.
"This is a quote."
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}