$re = '/^[a-z]{2,99}(?!(?<=View))Model$/im';
$str = 'MyModel
MyViewModel
MyView
kjahdkjaModel
akjsdhakjdhskadModel
tkajhsdkjhaModel
jModel
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);