$re = '/user=(?<id>[^&]+)/m';
$str = 'http://scholar.google.com/citations?hl=en&user=zRG3OwoAAAAJ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);