re = /[ |\t]+\*\s+@access\s+(?:private|protected|public)\n/m
str = '
* @access public
* @access public
* @access protected
* @access private
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end