# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Vortag<\/td>.*?\n?.*?<td>(-?\d+\.?\d+)<"
test_str = ("\n"
" <div id=\"divInfo\" class=\"cInfo\">\n"
" <table border=\"0\" cellspacing=\"0\" cellpadding=\"0\" width=\"100%\" height=\"100%\">\n"
" <tr>\n"
" <td align=\"center\">\n"
" <table class=\"tablebody\" border=\"0\" width=\"100%\">\n"
" <tr>\n"
" <td class=\"cNavInfo\">Online-Werte » Wechselrichter-Übersicht</td>\n"
" </tr>\n"
" </table>\n"
" </td>\n"
" </tr>\n"
" <tr><td> </td></tr>\n\n"
" <tr>\n"
" <td class=\"tablebody\">\n"
" <table width=\"100%\" border=\"0\">\n"
" <tr class=\"tablehead\">\n"
" <td colspan=\"7\"><strong>Summe aller Wechselrichter</strong></td>\n"
" </tr>\n"
" <tr>\n"
" <td class=\"tablehead\">Bezeichnung</td>\n"
" <td class=\"tablehead\">Wert</td>\n"
" <td class=\"tablehead\">Einheit</td>\n"
" <td> </td>\n"
" <td class=\"tablehead\">Bezeichnung</td>\n"
" <td class=\"tablehead\">Wert</td>\n"
" <td class=\"tablehead\">Einheit</td>\n"
" </tr>\n"
" <tr>\n"
" <td>Aktuelle Leistung</td>\n"
" <td><b>8.404</b></td>\n"
" <td>kW</td>\n"
" <td> </td>\n"
" <td>Aktuelle Monatsenergie</td>\n"
" <td>1750.106</td>\n"
" <td>kWh</td>\n"
" </tr>\n"
" <tr>\n"
" <td>Aktuelle Tagesenergie</td>\n"
" <td><b>15.328</b></td>\n"
" <td>kWh</td>\n"
" <td> </td>\n"
" <td>Aktuelle Jahresenergie</td>\n"
" <td>2352.722</td>\n"
" <td>kWh</td>\n"
" </tr>\n"
" <tr>\n"
" <td>Tagesenergie Vortag</td>\n"
" <td>148.736</td>\n"
" <td>kWh</td>\n"
" <td> </td>\n"
" <td>Gesamtenergie</td>\n"
" <td>235217.714</td>\n"
" <td>kWh</td>\n"
" </tr>\n"
" </table>\n"
" </td>\n"
" </tr>\n"
" <tr><td> </td></tr>\n\n"
" <tr>\n"
" <td>\n"
" <table width=\"100%\" border=\"0\" class=\"tablebody\">\n"
" <tr class=\"tablehead\">\n"
" <td colspan=\"5\"><strong>Übersicht einzelner Wechselrichter</strong></td>\n"
" </tr>\n"
" <tr class=\"tablehead\">\n"
" <td width=\"10%\">Adresse</td>\n"
" <td width=\"10%\">Leistung</td>\n"
" <td width=\"15%\">Einheit</td>\n"
" <td width=\"10%\">Tagesenergie</td>\n"
" <td width=\"55%\">Einheit</td>\n"
" </tr>\n"
"<tr><td CLASS=\"cLink\"><A HREF=\"/httpGpmGotoWrID.cgi?0\">1</A></td><td>2505</td><td>W</td><td>4.536</td><td>kWh</td></tr><tr><td CLASS=\"cLink\"><A HREF=\"/httpGpmGotoWrID.cgi?1\">2</A></td><td>2552</td><td>W</td><td>4.880</td><td>kWh</td></tr><tr><td CLASS=\"cLink\"><A HREF=\"/httpGpmGotoWrID.cgi?2\">3</A></td><td>693</td><td>W</td><td>1.304</td><td>kWh</td></tr><tr><td CLASS=\"cLink\"><A HREF=\"/httpGpmGotoWrID.cgi?3\">4</A></td><td>2524</td><td>W</td><td>4.608</td><td>kWh</td></tr>\n"
" </table>\n"
" </td>\n"
" </tr>\n"
" <tr><td> </td></tr>\n"
" <tr><td align=\"center\"> </td></tr>\n"
" <tr><td> </td></tr>\n"
" <tr><td align=\"center\"> </td></tr>\n"
" <tr><td height=\"100%\"> </td></tr>\n"
" <tr>\n"
" <td align=\"center\">\n"
" <table width=\"100%\" border=\"0\" class=\"tablebody\">\n"
" <tr>\n"
" <td>Anmerkung: Die hervorgehobenen Werte werden alle 20s aktualisiert.</td>\n"
" </tr>\n"
" </table>\n"
" </td>\n"
" </tr>\n"
" <tr><td> </td></tr>\n"
" <tr><td> </td></tr>\n"
" </table>\n\n"
"<div class=\"x-align-right\">\n"
" <div class=\"cStatuszeile\"> Systemzeit 10:35:57 / 24.02.2018 </div>\n"
"</div>\n"
" </div>\n"
" </body>\n"
"</html>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.