re = /"\w+(?:\.\w+)+\.(\w+)":\s*{/m
str = '[
{
"key1": "value",
"key2": {
"word1.word2.word3.word4.interestingPart": {
"key1": "value",
"key2": "value"
}
},
"key3": "value"
},
{
"key1": "value",
"key2": {
"word1.word2.word3.word4.word5.word6.thisIsAlsoAnInterestingPart": {
"key1": "value",
"key2": "value"
}
},
"key3": "value"
}
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end