using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*xxxx).*/en\/?$";
string input = @"https://xxxx.yyyy.com/en
https://xxx.yyyy.com/en
https://xx.yyyy.com/en/more here";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}