$re = '/(?<!\\\\)\,/i';
$str = 'abc\\def <- match
abc\\\\def <- wtf?
abc,def
abc\\,def
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);