# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:(?<![^/\[(|=<>!+*-:])
|
(?<=\s(?!and\b|or\b|mod\b|div\b)))
(?=(?:[^'\"]*(?:'|\")[^'\"]*(?:'|\"))*[^'\"]*$)
(?![a-zA-Z][a-zA-Z\d_.-]*[\(:])
([a-zA-Z][a-zA-Z\d_.-]*)
"""
test_str = ("PriceInfos/PriceInfo[@PriceTypeCode='26'] or PriceInfos/PriceInfo[@PriceTypeCode='35'] or \n"
" PriceInfos/PriceInfo[@PriceTypeCode='53'] or PriceInfos/PriceInfo[@PriceTypeCode='54'] or \n"
" PriceInfos/PriceInfo[@PriceTypeCode='55'] or PriceInfos/PriceInfo[@PriceTypeCode='56' and not(contains(@CodeDetail,'SINGLE SUPPL'))] or PriceInfos/PriceInfo[@PriceTypeCode='62']\n")
subst = "*[local-name()='\\1']"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.