#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!\A),\s*|X509v3 Subject Alternative Name:\s+)(DNS|IP Address):([\w.]+)"
Local $sString = "X509v3 extensions:" & @CRLF & _
" X509v3 Subject Alternative Name:" & @CRLF & _
" IP Address:55.66.77.88, DNS:example.com, DNS:www.example.com, IP Address:44.33.22.11" & @CRLF & _
"Signature Algorithm: sha384WithRSAEncryption"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")