const regex = /"Descr": ".*"\s*}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"Descr": ".*"\\s*}', 'gm')
const str = `"Descr": "Digital Input 0.1"
}`;
const subst = `"Descr": ".*", "Addr": `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);