import re
regex = re.compile(r"(\w+){2,}")
test_str = ("These are words \n"
"they killed a deer\n\n"
"$!@#abcd^#$%# 1234\n\n"
"(hi&)\n\n"
"Poproszę pieczonego ziemniaka UA-AA.\n"
"Poproszę miejsce na balkonie.\n"
"Poproszę piwo.\n"
".Poproszę piwo, stek z frytkami i specjalną sałatkę szefa.\n"
"Poproszę czarno biały film.\n"
"Poproszę koc i poduszkę FAA:kol JF-109.\n"
"Poproszę. koc i poduszkę 45-minutoowe.\n"
"Poproszę .koc. * 1-2\n"
"Poproszę modelowanie włosów John-3:16.\n"
"Poproszę jajko na twardo, sok pomarańczowy i chleb.\n\n"
" , | | . , , ∩ ゚ ∀ ゚ . ━ ━ ━ ┗ 。 ◕ ‿ ‿ ◕ 。 . ↑ ? ? ? . ☆ , 。 ・ ・ ゚ ・ ・ ゚ ★ . ๏ ๏ ๏ ๏ ๏ ๏ , ๏ ๏ ๏ ๏ ๏ ๏ ♥ . ░ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ █ █ ─ █ █ ▀ █ █ █ ▀ █ █ █ ▀ █ █ █ ─ █ ─ █ █ ─ █ █ ▀ █ █ █ ─ ─ █ █ ▀ █ ─ █ ▀ █ █ ▀ █ █ █ ─ █ █ █ ▀ █ █ ▀ ▌ █ ▀ █ ▌ ▀ █ ▌ █ ▀ ▀ ▌ █ ▀ ▀ ▀ ▌ █ ▀ ─ ▌ █ ─ █ ▌ ▀ █ ▌ █ ─ ─ ▌ █ ▀ ▌ █ █ ─ ▌ █ ─ ▌ █ ▌ █ █ ▌ █ ▀ ▀ ▌ █ ▀ ▀ ─ ▀ ▀ ─ ▀ ▀ ▀ ─ ─ ▀ ▀ ─ ─ ─ ▀ ▀ ─ ─ ─ ▀ ▀ ─ ▀ ─ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ─ ▀ ─ ▀ ▀ ─ ▀ ▀ ▀ ─ ▀ ▀ ▀ ▀ ▀ ▀ ▀ ░ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ❀ ♥ ♥ ❀ ♥ ❀ ♥ D AY . ● ▬ ▬ ▬ ▬ ▬ ▬ ▬ ๑๑ ▬ ▬ ▬ ▬ ▬ ▬ ▬ ▬ ● . ● ▬ ▬ ▬ ▬ ▬ ๑๑ ▬ ▬ ▬ ▬ ▬ ▬ ● . ( - 。 - ) zzZZZ .")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")